m999i EXTREMELY BAD Battery life.

So excited when I finally got my m999i. I put it out with new Energizer Lithium batteries and came back a week later to find that the batteries COMPLETELY DIED in the first few days. And I only had a dozen pictures. That is so bad it is borderline criminal. This is the first time I have ever bought a Moultrie cam (I heard they were good) but I'm unlikely to ever purchase again.

I checked, and my camera has the most recent firmware. So does anyone else have any ideas of what could be wrong?

Thank you.

Comments

  • Something is 100% wrong. I have a M999i and can normally get about 6 months on a set of lithiums with a handful of pics each day.

    It sounds like something is staying on which is draining your batteries.

    The other thing I would mention is to try a new set of batteries. Maybe not the expensive lithiums. Not too long ago I got a new package of batteries and about half of them were bad. Not the likely cause, but it's certainly possible.

  • huntress any luck with your issues of batteries not lasting. I have same issue and using the latest firmware.

  • I have the same problem with my M-999i. Not happy. Going broke getting batteries to take pictures of leaves and trees swaying in the breeze. Really sensitive.

  • If it's a sensitivity issue, there is an option in the settings to turn the sensitivity down - you might try that and see if it makes any difference

  • I had similar problems with my S50i. It took great photos, but was just a battery hog. Performance was no better when I bought a 12v battery for it because the camera ran on 18v so as soon as the battery level dropped to about 12v, it stopped recording. Sent the camera back and bought a Browning Dark Ops Pro XD and have never looked back. Amazed at its low power usage - even on video - using only 6 AAs and it takes great photos. Moultrie are just dinosaurs.

Sign In or Register to comment.