Moultry a20i trail camera

I purchased a moultry a20i trail camera last year and it worked okay, pictures were not the best but this year it will not work. I have free batteries in the camera and it turns on but when I insert an SD card, the display says CARD instead of the count down it normal gives to activate the camera. I have tried multiple different types of SD cards and that’s not it, batteries are brand new. I sent moultry an email asking for help with no response so if anyone has experienced this please respond with suggestions. Thanks

Comments

  • Since you've tried multiple cards, we can rule out the SD itself being locked and a corrupt card, your next step is to try and clean the SD card port. It's possible some debris got into the slot. You can use one of the cans of air (Keyboard cleaners) and spray it out.

    If that doesn't work, it's probably going to require a Customer Service call.

  • I figured it out you have to format the SD card on the computer to the 32 setting. Insert the SD card in the computer go to computer rt click on the sad card and go to format and click on the 32 setting then your done.
  • @jlnellist you didn't happen to notice what it was formatted to at the start did you? I'm curious if certain cards are starting to come formatted with NTFS or exFAT which could be problematic (the exFAT more than NTFS).

Sign In or Register to comment.