S-50i dead after firmware update

Pretty much says it all! My camera had been dormant for 6 months (solar panel failed). Also, received the new 4G modem during this time (it works fine). Modem instructions said to make sure to upgrade firmware on camera. I did the upgrade, it said "successful" then appeared to try to reboot. Camera powered off and NEVER came back! Have tried the hard reset, no luck. Batteries are fine. SD card shows the firmware is there, no pictures are on card. Totally stumped. Worked fine before the firmware upgrade. Any help would be greatly appreciated!


  • edited August 2019
    I remember not too long ago Apple killed a lot of their watches with an update.-not saying that's what happened here, but anytime you start adding files to a device's processing system, it contains an inherent risk.

    That being said, I would take the batteries out, turn the camera on, press buttons to completely drain all power, then reinstall the batteries and turn it back on. I would take the SD card out when you power it back up as well just in case there is something foreign on the card.
  • Thanks for the advice. I deal with computers every day and I agree. The more you add the worse it gets. However, in this case, it still doesn't work, even after the hard restart process. Thankfully, it's still under warranty so I'm sending it in today. I appreciate your response.

Sign In or Register to comment.