The Moultrie Forums Are Moving!

We are excited to announce the Moultrie Forum is migrating to a new platform and new location! The new forum connects directly with Moultrie’s customer service platform allowing our team to better integrate into the conversation. It is also a great opportunity to streamline the forums and start fresh conversations.

What you need to know:
• You need to create a new username and login on the new forum. Go to https://pradcooutdoorbrands.zendesk.com/hc/en-us/community/topics.
• The current forum will close on October 9th, so we encourage you to migrate to the new platform quickly.
• The new forum connects with Zendesk allowing you quick access to FAQs and even view your open tickets with Customer Service.

Need some encouragement?
• Everyone who creates a new account on the new forum is eligible to win a sweepstakes!
• Look for the Sweepstakes thread in the “General Discussion” section of the new Moultrie Forum. Then, simply post in that thread, “I’m here” for a chance to win a $500 gift card to moultriefeeders.com

Lastly, the Moultrie Team wants to thank each of you for participating in the conversations thus far. You are building a great community in which users can share stories, give advice, and help each other become better hunters. We will be monitoring and helping where needed.

We cannot wait to see you over there!

Thank you,
Team Moultrie

Moultrie Mobile Crap

Purchased a brand new one today with the A300i camera. Everything worked OK in my house, went to the field and pissed around leaving scent for an hour trying to figure it out while talking to customer service. Went to " level 2 tech" and she said i needed to use an 8gb sd card because the 16 i was using was causing trouble btwn the modem and camera. I switched it out to an 8 i have in another camera and still nothing. It seems to go thru the start up fine but i noticed the "camera" light never illuminates. Im wondering why that is? Either way, seems to be a P.O.S. from everything i have been reading on forums. Im calling again tmrw to vent.

Comments

  • Have same problem can't reach customer service except thru email. Got 3 attempts and same boiler plate stock email about battery, SD card etc. No camera light even though it worked on MV1 had. Fed up removed mv2 now it won't reactivate. overall I will just cancel membership and go back to going to the camera to get my pictures. Anyone want to buy 3 moutrie cameras? I'm thru with their products.

Sign In or Register to comment.